Have you tried with just DugiGuides enabled, and all other addons disabled?

    Once you have just DugiGuides running solo, try a few quests, and eventually enable one addon at a time until you see the issue, whatever addon it is, look through the configs/settings for that addon.
    The following addons are a few that I know of that highlight / select quest rewards.
    ElvUI (General > Quests | Uncheck Mark Quest Reward.)
    MerathilisUI (Miscellaneous > Quest | Uncheck Highest Quest Reward.)
    WindTools (Quest > Turn In > Reward | Uncheck Select Reward or Uncheck Enable.)
    There are two conditions within DugiGudies, however they aren’t “selecting”.
    Settings for Dugi Gudies > Gear Scoring > Loot Suggestion Priority. This is responsible to providing upgrades (Green arrow, Yellow arrow, Orange arrow etc.) and Gold coin icons on highest vendor price.
    They are “Active Talent Specialization” & “Highest Vendor Price”. I suggest to tinker with them, if the previous suggestion does not resolve this issue.