Dugi Guides™ | World of Warcraft Leveling Guides © 2010 – 2024 Forums Troubleshooting DG Menu and Extra Tracking Module Menu background issue

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #163959

    Hello team,

    I have some trouble since several day, the DG  & Extra Tracking Module menu are transparent.
    This is not very convenient / readable especially the tracking menu for which we do not have the possibility to move.
    See the below screen shot :

    Many thanks in advance for your help.


      Are you using any other addon like MoveAnything?

      The dugiguides addon needs to have absolute 100% control, any other addon that takes this control funny things like above happens. If you really need the second addon look through its options and uncheck anything to do with the Objective Tracker.
      You can try to disable all addons except dugi guides, if dugi guides is doing the same thing, I’d do the following
      /dugi fix
      click okay and after reload, log out.
      log back on to the character.
      /dugi reset
      If the issue still remains, I’d exit out of World of Warcraft completely including the battle.net launcher.
      Open up the Dugi Guides Installer, click on the Settings button.
      Click on the Repair, wait until a confirmation window appears, click on the Okay button, and then Okay button again.
      Click on the Reinstall button if it doesn’t automatically download.

        I think this is to do with the UI addon, can you tell the me the UI addon you’re using and we probably can fix it. 

          In the first screenshot posted by the op you can see it is the right chat with datatexts ‘System | Elvui Config | Gold’. However not sure if it’s vanilla elvUI or someone’s edit as in MerathilisUI.
          It’s rather odd for ElvUI to take control of the Objective Tracker like that, though, I haven’t tried any others except vanilla ElvUI/TukUI, MerathilisUI, MaxUI and BenikUI.
          I’d expect UI addons like SyncUI and RealUI to do this, they did have 100% control of the Objective Tracker back in Legion, I am guessing they still do it now in BfA. For SyncUI that was absent in Legion, so last known expansion was Warlords of Draenor.
          RealUI was a real pain to turn it’s Objective Tracker tampering off without total rewrite of it’s code, was successful, but wasn’t worth to note the edits. SyncUI has an inbuilt enable / disable setting which was handy.
          Out of curiosity I enabled the feature “Movable Frames” within ProjectAzilroka addon and I don’t get what op has posted. Which is why I initially fixated on a known addon called ‘Move Anything’ looking at the same behavior when the Objective Tracker is targeted within ‘Move Anything’ addon.
          I guess we will have to wait until op lists the addon’s he is using. [op] = original poster

          Dear Dugui, Caluril,

          I have de-activated all addons and the menu is OK. I have done the test with only the UI addon activated ELvUI and the menu issue is present.
          I confirm that i use the standard ElvUI.
          Many thanks for your help.


            Thanks for confirming, Try the last part of my first reply, to open up Dugi Auto Installer and perform a Repair, see how that goes.

            Test again with only Dugi Guides enabled.
            As for ElvUI, ElvUI does have an option for the Objective Tracker, to change the Quest Item Left side or the Right side. So, if you use /moveui you can drag the Objective Tracker to where you want it and control the side the Quest Item goes.
            Soon as Dugi Guides is installed & activated, Dugi Guides takes 100% control and the ElvUI move & Quest Item features are automatically disabled. Doubt it’s ElvUI.
            I would also consider doing this if the Dugi Installer Repair doesn’t work.
            Go inside your World of Warcraft installation folder:<your path>World of Warcraft_retail_
            Delete the folders ‘Cache‘ & ‘Interface‘ & ‘WTFyou could just move them to the desktop under ‘New Folder’ for the time being.
            Run the Wow.exe, select your language and exit the into clip to get to the main menu. Exit the game.
            Either download the ElvUI package from tukui.org or from the client, I use the client, easier to install base UI and UI addons like addonskins.
            Install Dugi Guides from the Dugi Installer, ensuring you go in the Settings and input your dugiguides.com username and password and verify the paths are correct
            World of Warcraft Install Path:<your path>World of Warcraft_retail_
            World of Warcraft Launcher Path:<your path>World of WarcraftWorld of Warcraft Launcher.exe
            Install Dugi Guides and check again.
            Don’t do all of this if the Repair worked.
            Can you please take a fullscreen screenshot with the menu issue? It might make it easier to see what is going on.

              Actually, in reference to the first screenshot; does that menu disappear when you left click once on the DG Icon? It should by rights appear from first left click and then disappear when left clicked again.
              In reference to the second screenshot, the Minimap menus appear when you right click the minimap; when I tried this I get the menus but no background or frame, just the menu options, Dugi. here’s a screenshot https://i.imgur.com/rd9Tv9K.png
              However, they don’t appear without myself clicking.


              Hello Caluril

              I have tried the full re-install as the repair doesn’t work. Anyway with only elvui and dugui the problem persist see enclose full screen only the a basic ElvUI configuration:

              For the minimap i have the same behaviour than yours.

                Okay for now go to your game path and move your Cache‘ & ‘Interface‘ & ‘WTF‘ folders to another folder somewhere like the desktop “temporarily”.
                Run the game and exit the trailer to get to the main menu and exit the game.
                Download and run the Dugi Installer
                Click on the Settings button.
                Input your dugiguides.com username and passwords in their appropriate fields.
                While in the settings, check your game path’s.
                Click on the Okay button and click on the Reinstall button if the installer doesn’t automatically start installing the guides.
                Once finished, run the game.
                Check to see if you are still getting the menu issue.

                  no need for you to do anything, this is a fix that needs to be done with Dugi addon, we’ll fix it up soon


                  Many thanks for your help Caluril  :)

                  Thanks Dugi for the incoming fix :smiley:



                  Just to confirm that my issue is solved with the latest version. :p

                  Many thanks


                    No problem 🙂

                  Viewing 13 posts - 1 through 13 (of 13 total)
                  • You must be logged in to reply to this topic.