Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #165205
    I haven’t seen a setting anywhere to control whether battle pets are shown or hidden on the maps. Is there one to toggle visibility without enabling/disabling Blizzard’s tracking ability? If there is not, are the icons supposed to always be shown? Or are they only supposed to show locations of pets you have not collected yet? As it is now, Stormwind Rat shows in various places while I am looking at the map of Stormwind. I have already collected the pet, so I would think it should not show it any longer but there it is, taking space on the map.
    If it does not work this way is it possible to add a toggle to show pets that are “not collected” only or make it so that showing them in general is toggle able outside of changing Blizzards tracking?
    Thank you !

      Hi vis1946,
      To enable / disable the Battle Pet tracking feature it’s controlled by the blizzard’s Track Pets mini map option. See attached image “Wow_9DTmyWGzeA.png”
      Checked = Enabled
      Un-checked = Disabled

      You can control what you see by checking / un-checking options within Dugi Guides Tracked Pets which appears under the blizzard mini map frame options.
      You would want to un-check the Collected if you don’t want the battle pet to appear if you’ve already obtained that pet. See attached image “image_2022-08-10_154414816.png”

      You can also control what kind of pets to show by checking or un-checking Battle Pet Race.

      Thank you! I’m not sure how I missed that menu, but I did. That solves one part of the problem.
      The remaining issue is that it is not recording what pets I do have. I now have it set to only show missing/not collected pets. When I look at the map, it still shows the icon for pets as if I had not collected them. For example, I have collected a lvl 1 Rare quality Stormwind Rat. When I look at the map of Stormwind, the icons are still there for that specific pet. Any idea what could be the cause of that?
      Thank you !
      Just for kicks I located and captured a new Stormwind Rat. It happened to be grey quality. Now the map correctly makes the icons disappear. I checked other locations as well vs my collection and they are showing/not showing icons properly also. So I have no idea whats happening.

        Well in that case, the “Not Collected” should do the trick.
        Able to post up a screenshot of the setting e.g. like my “image_2022-08-10154414816.png” and another showing the icons in question?


          I have tested yet again.
          Tracked Pets > Collected & Not Collected checked.
          See file “image_2022-08-14-182817956.png”

          Tracked Pets > Collected unchecked and Not Collected checked.
          See “image_2022-08-14-183011364.png”

          Clearly it’s working because I have already collected the Stormwind Rat.

          I am going to test on another account the quality of the battle pets, because I have three types of Stormwind Rat, poor, common and rare all at level 25.

          It’s very strange. Now looking at a different toon on the same account and faction and the same thing is happening again. Here’s a couple screenshots.

            I am not sure what’s going on here, I am unable to replicate this issue even on different characters and other accounts.


              might be cache issue, it should eventually fix itself after a relog or reload 

              As an update, the issue is still occurring. Here are the results of the testing I did.
              I removed my WTF and Interface folders. I logged into WoW and let it rebuild the folder structure and contents then exited and closed the game. I installed a fresh/latest version of the Guide via the installer. I then logged in and checked the tracking menus (Guides and WoW’s). I am using Stormwind as a test area for it’s ease of access and small number of pets. I set up the options so that I am tracking pets via WoW’s options and also choosing to only show Not Collected pets via Guide Options on the Maps. Currently, the icon for the Stormwind Rat shows on the map and states I have not collected it.
              I made sure to open and close the Pet Journal. No change.
              I left the Stormwind zone and re entered it. No change.
              I entered a pet battle with a Stormwind Rat and forfeited. No change.
              I entered a pet battle with a Stormwind Rat and caged it. The map shows correctly now.
              I inspected multiple zones and checked what was shown as Not Collected vs my Pet Journal and it was all showing properly now. For completeness, I logged into several other characters and found them all to be displaying collected and not collected properly.
              It appears that the information did not get saved/updated/requested in the Guides database until the pet battle event of successfully caging a pet occurred. I’m not sure what event the Guide looks for to update it’s database.

                I made another account and this did not happen.
                I caught the Stormwind Rat, exited WOW, deleted Cache, Interface, WTF folders.
                I re-entered the game and unchecked collected and the Stormwind Rat no longer appears on the map as intended. A pet battle was not necessary to trigger the map to show correctly.
                I caught several qualities, including poor, which I repeated above in order for the map display correctly.
                I released poor and caught common, I then repeated above in order for the map display correctly.
                I released common and caught rare, I then repeated above in order for the map display correctly.

                I also repeated the above without deleting folder’s as Dugi said earlier, a relog or reload

                /console ReloadUI

                I’m not sure why it’s not working for you.

                Thank you for taking the time to test and double check. I’m really not sure why it didn’t operate that way for me as well. Thankfully it’s not something that has to be done at each log in and is only needed when I have reinstalled addons from scratch.
                Thank you again though. The effort is very much appreciated.
              Viewing 11 posts - 1 through 11 (of 11 total)
              • You must be logged in to reply to this topic.