Oh my! that’s not normal. Do you use a third party anti virus / security application by any chance? Like Avast or AVG or TrendMicro to name a few.

    If you are, try to + Allow App “DugiGuides_1.5.3.exe”
    Each of the third party applications have their own areas where this resides, a google search “How to allow app in {name of security software}” replace name of security software with something like Avast.If the security software does not support that feature then add “DugiGuides_1.5.3.exe” in to the Exceptions. A google search like “How to exclude an application in {name of security software}”.
    Normally, installing two antivirus programs on the one machine can cause something like this, Windows 10 or 11 already has an antivirus called Windows Defender, this can be disabled. Though according to the Microsoft documentation on Windows Defender, it’s supposed to auto detect and disable itself to allow the third party software to work, but my tests prove that it doesn’t completely disable.

    To test, try disabling your third party security software and then run DugiGuides_1.5.3.exe and try to do an update or reinstall.

    If it still crashes, then try looking at the paths. Click on the Settings button and then check the following paths:

    • Retail = PathWorld of Warcraft_retail_
    • Classic TBC/Wrath = PathWorld of Warcraft_classic_
    • Classic = PathWorld of Warcraft_classic_era_

    Don’t forget, if you don’t have Classic TBC/Wrath and/or Classic Era you can check the boxes “Ignore TBC” or “Ignore Classic Era”.
    Test again with third party security disabled.

    Can you please tell me What version of windows are you using? Windows 10 or Windows 11