For Classic Era and Wrath Classic, type /dugi config, then click Talent Advisor > Templates, and then select one of the specs for your current character. It is set to None by default.
    After you’ve chosen your character’s spec, hit N and you should see symbols in a corner of the set of abilities.
    I am now unable to give any screenshots since due to the new adjustments made during the Classic Era release, my character’s level has been crushed; I am in the process of resolving that issue.

    The Talent Advisor is not accessible for Retail. You may locate it under Settings > Other > Talent Advisor checkbox.
    It makes no difference whether you tick or uncheck it. I’m not sure what’s going on; the last I heard, it was in the todo list of redevelopment alongside other priorities on the same list.