Dugi Guides™ | World of Warcraft Leveling Guides © 2010 – 2024 Forums Troubleshooting WOTLK classic Getting LUA errors after updates

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #165465
    thunderpaw
    Participant

      Hi, I’m getting LUA updates in Zangarmarsh leveling. It looks like map errors. 

      I deleted my Dugis guides folders in addons and reloaded it but still same errors. I dont get these errors in the classic zones, only TBC zones. I only have one character high enough to be in these zones. Any suggestions. I’m attaching the error streams. I get them every time I open the map.

      #167864
      Ozzi
      Participant

        The addon is not totally removed by just deleting the folder in the AddOns folder.
        Before you proceed, ensure that World of Warcraft is not running.
        Open up the Dugi Installer and click Settings button and then click on Repair button, then click on Okay x3 times, finally click Okay to exit the Options. Exit the Dugi Installer and then load up World of Warcraft and check to see if you get any .lua errors. If you do, then it’s not Dugi Guides.
        The Repair button will remove all folders in Addons and WTF [Savedvariables] (user and account).

        Open up the Dugi Installer and click on the Settings button and check your Username and Password, click on the Okay button and then click on Reinstall button to install the guides. If you are getting .lua errors you will need to now disable ALL addons except Dugi Guides, then you can then enable one addon at a time until you can find the culprit. Note the name and then use the CurseForge website and find the addon that’s causing issues and then use their report a bug or ticket to report to them the issue you are having.

        #170642
        thunderpaw
        Participant

          I just did this and still getting errors. Same ones I attached. The only enabled Addon is Duigis. 

          I did both the Repair then when that didn’t work I did the reinstall. Same issue. Seems to happen when I open a map or the waypoint arrow gets updated. I can watch it climb into the 4,000 counts  The main error I keep seeing is attempt to call method ‘AssignQuestNumber’ (a nil value).

          This almost seems character specific. I dont get this error when playing my lower level characters in WOTLK classic, and I dont get it in classic era or retail, just on my character currently leveling in Zangarmarsh. 

          #170643
          thunderpaw
          Participant

            Working now…I think. 

            I did all the things, renamed WTF/Cache. Repaired and reinstalled Dugis. 

            Eventually I found when I opened the map, there was a check mark in the lower left corner of it that showed ‘when enabled, you will be able to look at your map to see quest objectives.” I unchecked this and the errors stopped. I rechecked it and they started again. Not sure what that is but doesn’t seem to be affecting dugis.

            #167863
            Ozzi
            Participant

              My Investigation

              1. I have my own addon as well as Dugi Guides and BugSack and BugGrabber running.
              2. At first I had DugiGuides disabled to see the interaction with the default map frames.
              3. I then enabled DugiGuides to see the issue at hand, mainly to see if I can trigger the error, though I got no error.
              4. I can see there is an issue with the ‘Minimize Map Button’ if that’s enabled there are out of place replica minimize and or X buttons. If you disable that feature all is good.

              I have made a recording of this bug and I will be submitting this to Dugi.

              See video here if Google still does not allow you to play the video online you would need to download it, my apologies.

              We are also aware that Blizzard has released the built in quest objectives in build 3.043, we are going to get one of our programmers to remove this feature from our guides, eta on this is unknown.

              Just a follow up, I am able to replicate the error, it is not map based, its dependent on the tracked quest in any zone, soon as you open the map window (m) you get the error.

              This is related to the new quest objectives as stated earlier. To fix this for now, open the map window (m) and then UN-tick Quest Objectives on the bottom left of the window.
              So the options to uncheck are Minimize Map Buttons and Quest Objectives.
              To see how this can be done, head on over to our Discord Server and then enter the Thread for this issue and follow the steps.
              #170647

              Thank you this info really helped had errors left  and right and this has temp solved the issue so far

              #170648
              mysti35
              Participant

                Just to chime in, when I do any quest (for example catch 10 terrorfish) the first terrorfish I catch, I get the “quest is complete” audio.  After I catch my 10th fish, I hear nothing.

                #167677
                Ozzi
                Participant

                  mysti35 said:

                  Just to chime in, when I do any quest (for example catch 10 terrorfish) the first terrorfish I catch, I get the “quest is complete” audio.  After I catch my 10th fish, I hear nothing.

                  To confirm, enter the settings /dugi config then click ⚙️ and then under Questing check that Map Ping is selected under Step Complete Sound and Default or whatever the preferred sound you want is selected under Quest Complete Sound.

                  If you use another addon, such as ProjectAzilroka, make sure that only Quest Complete has a sound selected, i.e for me: Carbonite; and that all others are set to None under QuestSounds. While the ProjectAzilroka addon is the addon inteded to be used for the usage of quest complete sounds, you must now ensure that Dugi Guides Quest Complete Sound is set to None, or you will receive two audible sounds every quest complete.

                  The sound you hear on the first 1/10 complete is called Objective Progression, which sounds more like another addon like ProjectAzilroka is in use.
                  #170652
                  mysti35
                  Participant

                    Checked this out Ozzi and I do not use anything like Azilroka.  All you asked me to check was correctly selected.  The guide still is working and the above is only a mild inconvenience.

                    #167663
                    Ozzi
                    Participant

                      As I just confirmed with you that Dugi Guides does not use sounds for Objective Progression. You can confirm this yourself by slowly clicking each category in the Dugi Settings in-game and look for a setting for Objective Progression Sounds.

                      #170653
                      mysti35
                      Participant

                        Isn’t there a setting in Dugi that allow you to pick a voice?  I always like the female Panda one.  Is this from some other addon?

                        #167626
                        Ozzi
                        Participant
                          There are two settings Step Complete Sound and Quest Complete Sound. We do not have Objective Progression Sound. Objective Progression Sound makes a sound when you pick up the first item of the ten or fifty items, which is what you described, which is defiantly another addon that’s doing that.
                          Here’s Dugi Guides quest and step sounds – here
                          Here’s a third party addon, for me it’s ProjectAzilroka – here
                          You may need to sift through your addons, it’s defiantly another addon that’s responsible for the progression sound.
                          #170657
                          mysti35
                          Participant

                            I will look more closely.  I was referring to the sound when a quest is COMPLETE.  Maybe this other addon is taking over.  I will check my Dugi settings.

                            Thanks.

                            #167618
                            Ozzi
                            Participant

                              My apologies; if it’s not an addon, it might be the result of Blizzard’s quest tracking system, which is now integrated into the game and is conflicting with our addon. One of our programmers is currently removing features that are conflicting with Blizzards. You might have to wait for the next update.

                              #170658
                              mysti35
                              Participant

                                Yes, I don’t understand why every time Blizz releases new content, they make EVERYONE who writes an addon, essentially fix their now broken program.

                                I do not think Blizzard realizes how critical addons have been to the success of WOW and the fact they keep ‘dumping on’ the addon authors just boggles my mind.  Lazy taken to new heights…reminds me of Microsoft releasing products as finished when in fact they are often barely past the alpha stage much less beta.

                              Viewing 15 posts - 1 through 15 (of 15 total)
                              • You must be logged in to reply to this topic.