Viewing 15 posts - 1 through 15 (of 37 total)
  • Author
    Posts
  • #164292
    gerardm23
    Participant

      Hi the problem that i am having is since the latest patch the guide doesnt seem to load properly it just shows a transparent background which the objective tracker cant be moved,it seems as if the guides arent loading properly,i have the lates guide build 8.770,hopefully you can help me to get this fixed as i cant live without the guides they are simply brilliant so accurate.

      #166852
      kjmymp
      Participant

        Same issue

        #166854
        Dugi
        Keymaster

          please post error, screenshot, test with only dugi enabled.

          #166859

          Build 8.771 is not loading automatically.  I have to manually click  Guide Mode  to get it to load.

          #166860
          gerardm23
          Participant

            Thank you most kindly indeed for the prompt reply dugi it is appreciated greatly i have attached the screenshots of the error that i am getting.

            #166861
            Everytime I log in the guide frame does not appear and there is no way to select a guide in the options screen.   A /reload fixes it but if I log out and back in again then I have to reload again.
            #166862

            I’m having a similar problem.
            But only on one character. 
            The different interface pieces aren’t wanting to appear properly or at all.
            Disabling all other addons and /reloading don’t work. I’ve tried clearing my cache and that didn’t work also.

            #166863
            jmneth1
            Participant

              All addons disabled except for DugiGuidesViewer 8.771.  The guide does not load.  I can click on the DG button and select off then the following lua error pops up:

              Message: InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:1967: attempt to index field ‘wayframe’ (a nil value)
              Time: Thu Sep 26 09:30:49 2019
              Count: 1
              Stack: InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:1967: attempt to index field ‘wayframe’ (a nil value)
              InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:1967: in function `Load’
              InterfaceAddOnsDugisGuideViewerZModules.lua:223: in function <InterfaceAddOnsDugisGuideViewerZModules.lua:221>
              InterfaceAddOnsDugisGuideViewerZModules.lua:312: in function <InterfaceAddOnsDugisGuideViewerZModules.lua:281>
              InterfaceAddOnsDugisGuideViewerZModules.lua:359: in function `ReloadModules’
              …erfaceAddOnsDugisGuideViewerZDugisGuideViewer.lua:5114: in function `TurnOff’
              …erfaceAddOnsDugisGuideViewerZDugisGuideViewer.lua:6680: in function <…erfaceAddOnsDugisGuideViewerZDugisGuideViewer.lua:6581>
              …erfaceAddOnsDugisGuideViewerZDugisGuideViewer.lua:6742: in function `func’
              …gisGuideViewerZLibsDropDownMenuUIDropDownMenu.lua:816: in function `LibDugi_UIDropDownMenuButton_OnClick’
              [string “*:OnClick”]:1: in function <[string “*:OnClick”]:1>
              Locals: (*temporary) = nil
              (*temporary) = nil
              (*temporary) = 0
              (*temporary) = <userdata>
              (*temporary) = true
              (*temporary) = nil
              (*temporary) = nil
              (*temporary) = nil
              (*temporary) = “attempt to index field ‘wayframe’ (a nil value)”
              lastUnitY = -1
              GPS = <table> {
               UpdateBorder = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:1158
               Scale = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:223
               AddPOIButton = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:346
               PlaceButtonsOutideMapIfNeeded = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:1086
               TryCreatingWorldQuestPOIDD = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:1555
               Zoom = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:645
               UpdateTitlePosition = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:425
               CurrentDistanceToEdges = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:835
               DrawQuestBlobs = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:364
               GetMapIdForGPSMap = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:73
               title = OVERLAY {
               }
               Unload = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:216
               GetWorldMapSize = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:84
               SetMapsAlpha = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:1386
               FixTopPosition = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:1064
               UpdateMinimapTextures = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:1607
               Update = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:1214
               RefreshWorldQuests = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:1464
               UpdateBigTexturesPositions = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:177
               SetSize = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:462
               ShouldLoad = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:154
               RefreshPOIs = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:373
               Options = <table> {
               }
               CheckIndoorsChange = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:718
               ResolveScale = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:852
               MoveMapToPoint = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:704
               CenterPlayerOnMap = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:273
               ClearTextures = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:1306
               LocalMapPoint2ScaledPixelMapPoint = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:698
               UpdateMode = <function> defined @InterfaceAddOnsDugisGuideViewerZGPSArrow.lua:885
               GetScaleYd

              I then click on Reload Interface, then click on Dugi Guides button and select Guide Mode.  Then the guide loads.  To get Dugi Arrow back I had to go to settings–>Dugi Zone Map–> uncheck Merge With Dugi Arrow.  When logging out or exiting WoW and restarting the game, Dugi Guides loads OK.  Everything seems normal now.

              #166864
              Dugi
              Keymaster

                Can you try 8.772 

                #166866
                gerardm23
                Participant

                  Hi tested 8.772,after logging in and reloading the ui the guide appears normally after pressing the guide mode button but the navigation arrow is still missing,hopefully this helps.Unchecking the option of merging the zone map with the dugi arrow doesnt make a difference sorry.

                  #166867
                  xjl808
                  Participant

                    i had a similar issue with the arrow now showing up after 8.25 on dugi version 8.770, after trying /dugi fix arrow came back.

                    #166869
                    Dugi
                    Keymaster

                      gerardm23 said:

                      Hi tested 8.772,after logging in and reloading the ui the guide appears normally after pressing the guide mode button but the navigation arrow is still missing,hopefully this helps.Unchecking the option of merging the zone map with the dugi arrow doesnt make a difference sorry.

                      do you still get any error?

                       can you test with only Dugi enabled, your screenshot have lots of addons loaded. Try typing /dugi fix 

                      #166871
                      gerardm23
                      Participant

                        after typing /dugi fix the guide appears normally when you select the guide mode button,the arrow also appears again,only when you logout and back in the frames reset there positions,basically you have to select the guide mode button on login every time you login for everything to appear normally,i have recorded a video of whats happening how would i send it to you it shows better whats happening.

                        #166873
                        Dugi
                        Keymaster

                          gerardm23 said:

                          after typing /dugi fix the guide appears normally when you select the guide mode button,the arrow also appears again,only when you logout and back in the frames reset there positions,basically you have to select the guide mode button on login every time you login for everything to appear normally,i have recorded a video of whats happening how would i send it to you it shows better whats happening.

                          can you use https://screencast-o-matic.com and it should automatically upload and provide with a link 

                          #166874
                          gerardm23
                          Participant

                            Hi i have uploaded the video of what is happening with the guides,hopefully this helps a bit ,i can confirm i only have dugi guides along with elvui&tsm loaded.
                            Thank you.The link for the video is as follows:-
                            https://screencast-o-matic.com/watch/cqQtnFufxw

                          Viewing 15 posts - 1 through 15 (of 37 total)
                          • You must be logged in to reply to this topic.