#170422
Ozzi
Participant

    Yes, that would be the Dugi Guides Pet Tracker module, to disable this module, right click on the Mini Map and then uncheck Track Pets. That should stop the cluster of pets showing up on both the mini map and the main map.