#169899
Dugi
Keymaster

    this try going to settings > maps > disable map preview for now